PHP7.2にアップデートすることで問題が発生することが確認されているプラグイン

Facebook

プラグインディレクトリ

https://ja.wordpress.org/plugins/facebook/

発生するエラー

PHP Fatal error:  'break' not in the 'loop' or 'switch' context in wp-content/plugins/facebook/social-plugins/widgets/like-box.php on line 84

対応

すでに何年も更新されておらず、また公開も停止されているプラグインのため、アンインストールと代替プラグインの利用をご検討ください
  

Taxonomy Terms Order

プラグインディレクトリ

https://ja.wordpress.org/plugins/taxonomy-terms-order/

発生するエラー ( ver.1.4.7 で確認済み )

PHP Fatal error:  Uncaught Error: Using $this when not in object context wp-content/plugins/taxonomy-terms-order/taxonomy-terms-order.php:136

対応

古いバージョンだとエラーが発生するため、最新版へのアップデートまたは代替プラグインの利用をご検討ください
 

Page Builder by SiteOrigin

プラグインディレクトリ

https://ja.wordpress.org/plugins/siteorigin-panels/

発生するエラー( ver.2.4.2 で確認済み )

PHP Fatal error:  Uncaught Error: [] operator not supported for strings in wp-content/plugins/siteorigin-panels/inc/css.php:27

対応

古いバージョンだとエラーが発生するため、最新版へのアップデートまたは代替プラグインの利用をご検討ください

Did this answer your question?